Multiple security issues were discovered in MySQL and this update includes a new upstream MySQL version to fix these issues.

In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes.

Um, excuse me? This is an LTS release of Ubuntu, yet in order to apply a security patch we need to deal with incompatible changes? [USN-2575-1] MySQL vulnerabilities

Maybe it’s time to switch back to RHEL, warts and all.